#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?:(?<=^tags::)|\G(?<!^))(\s*\w+)(?= )"
Local $sString = "some random text" & @CRLF & _
"tags:: tree dog book razor" & @CRLF & _
"some random text" & @CRLF & _
""
Local $sSubst = "$1,"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)