re = /(?:(?<=^tags::)|\G(?<!^))(\s*\w+)(?= )/m
str = 'some random text
tags:: tree dog book razor
some random text
'
subst = '$1,'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result