const regex = /(?:(?<=^tags::)|\G(?<!^))(\s*\w+)(?= )/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:(?<=^tags::)|\\G(?<!^))(\\s*\\w+)(?= )', 'gm')
const str = `some random text
tags:: tree dog book razor
some random text
`;
const subst = `$1,`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);