using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*[0-9]+:[0-9]+:[0-9]+ ";
string input = @"drwxrwxrwx 4,096 2018/12/10 15:27:39 test/dir/one
drwxrwxrwx 4,096 2018/12/10 15:27:39 best/folder/two";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}