re = /.*[0-9]+:[0-9]+:[0-9]+ /m
str = 'drwxrwxrwx 4,096 2018/12/10 15:27:39 test/dir/one
drwxrwxrwx 4,096 2018/12/10 15:27:39 best/folder/two'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end