import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*[0-9]+:[0-9]+:[0-9]+ ";
final String string = "drwxrwxrwx 4,096 2018/12/10 15:27:39 test/dir/one\n"
+ "drwxrwxrwx 4,096 2018/12/10 15:27:39 best/folder/two";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}