package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).*[0-9]+:[0-9]+:[0-9]+ `)
var str = `drwxrwxrwx 4,096 2018/12/10 15:27:39 test/dir/one
drwxrwxrwx 4,096 2018/12/10 15:27:39 best/folder/two`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}