const regex = new RegExp('\\bNon-GAAP\\b.*?\\b(\\d+\\.\\d{2,})\\b', 'gm')
const str = `Non-GAAP-2 net income of with EPS of 1.21, up 23% from the fourth quarter of 2020.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}