// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\bNon-GAAP\b.*?\b(\d+\.\d{2,})\b").unwrap();
let string = "Non-GAAP-2 net income of with EPS of 1.21, up 23% from the fourth quarter of 2020.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}