$re = '/\bNon-GAAP\b.*?\b(\d+\.\d{2,})\b/m';
$str = 'Non-GAAP-2 net income of with EPS of 1.21, up 23% from the fourth quarter of 2020.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);