use strict;
my $str = 'Non-GAAP-2 net income of with EPS of 1.21, up 23% from the fourth quarter of 2020.';
my $regex = qr/\bNon-GAAP\b.*?\b(\d+\.\d{2,})\b/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}