#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^[\D]*(?P<from_day>(0?[1-9])|([12][0-9])|3[01])[\.\-\s,■]+(?P<from_month>(0?[1-9])|(1[0-2]))[\.\-\s,■]*(?P<until_day>(0?[1-9])|[12][0-9]|3[01])[\.\-\s,■]+(?P<until_month>(0?[1-9])|1[012])[\D]*$|(?:.*)"
Local $sString = "28.11 16.12" & @CRLF & _
""13.01 23,09"" & @CRLF & _
"01.08.-31.12" & @CRLF & _
""01.01,-51.12"" & @CRLF & _
"01.08.-31.12." & @CRLF & _
"01.08.-31.12." & @CRLF & _
"01.01.-31.12." & @CRLF & _
"01.08.-31.12." & @CRLF & _
"01.01.-31.12." & @CRLF & _
""01,01.-31,12."" & @CRLF & _
"01083112" & @CRLF & _
"1.02 - 4.3"
Local $sSubst = "\g<from_day>.\g<from_month>-\g<until_day>.\g<until_month>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)