import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[\\D]*(?P<from_day>(0?[1-9])|([12][0-9])|3[01])[\\.\\-\\s,■]+(?P<from_month>(0?[1-9])|(1[0-2]))[\\.\\-\\s,■]*(?P<until_day>(0?[1-9])|[12][0-9]|3[01])[\\.\\-\\s,■]+(?P<until_month>(0?[1-9])|1[012])[\\D]*$|(?:.*)";
final String string = "28.11 16.12\n"
+ "\"13.01 23,09\"\n"
+ "01.08.-31.12\n"
+ "\"01.01,-51.12\"\n"
+ "01.08.-31.12.\n"
+ "01.08.-31.12.\n"
+ "01.01.-31.12.\n"
+ "01.08.-31.12.\n"
+ "01.01.-31.12.\n"
+ "\"01,01.-31,12.\"\n"
+ "01083112\n"
+ "1.02 - 4.3";
final String subst = "\\g<from_day>.\\g<from_month>-\\g<until_day>.\\g<until_month>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}