use strict;
my $str = '28.11 16.12
"13.01 23,09"
01.08.-31.12
"01.01,-51.12"
01.08.-31.12.
01.08.-31.12.
01.01.-31.12.
01.08.-31.12.
01.01.-31.12.
"01,01.-31,12."
01083112
1.02 - 4.3';
my $regex = qr/^[\D]*(?P<from_day>(0?[1-9])|([12][0-9])|3[01])[\.\-\s,■]+(?P<from_month>(0?[1-9])|(1[0-2]))[\.\-\s,■]*(?P<until_day>(0?[1-9])|[12][0-9]|3[01])[\.\-\s,■]+(?P<until_month>(0?[1-9])|1[012])[\D]*$|(?:.*)/mp;
my $subst = '\\g<from_day>.\\g<from_month>-\\g<until_day>.\\g<until_month>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";