# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^[\D]*(?P<from_day>(0?[1-9])|([12][0-9])|3[01])[\.\-\s,■]+(?P<from_month>(0?[1-9])|(1[0-2]))[\.\-\s,■]*(?P<until_day>(0?[1-9])|[12][0-9]|3[01])[\.\-\s,■]+(?P<until_month>(0?[1-9])|1[012])[\D]*$|(?:.*)"
test_str = ("28.11 16.12\n"
"\"13.01 23,09\"\n"
"01.08.-31.12\n"
"\"01.01,-51.12\"\n"
"01.08.-31.12.\n"
"01.08.-31.12.\n"
"01.01.-31.12.\n"
"01.08.-31.12.\n"
"01.01.-31.12.\n"
"\"01,01.-31,12.\"\n"
"01083112\n"
"1.02 - 4.3")
subst = "\\g<from_day>.\\g<from_month>-\\g<until_day>.\\g<until_month>"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.