#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?=.*[a-zA-Z])(\S+-\S+-\S+)"
Local $sString = "This 1-A16-19 person is BL-17-1111 and other" & @CRLF & _
"dont Z-1-12 do here but NOT 12-24-1981" & @CRLF & _
"numbers: 1A-256-29Q88 ok"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")