import re
regex = re.compile(r"(?=.*[a-zA-Z])(\S+-\S+-\S+)", flags=re.MULTILINE)
test_str = ("This 1-A16-19 person is BL-17-1111 and other\n"
"dont Z-1-12 do here but NOT 12-24-1981\n"
"numbers: 1A-256-29Q88 ok")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")