$re = '/(?=.*[a-zA-Z])(\S+-\S+-\S+)/m';
$str = 'This 1-A16-19 person is BL-17-1111 and other
dont Z-1-12 do here but NOT 12-24-1981
numbers: 1A-256-29Q88 ok';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);