import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=.*[a-zA-Z])(\\S+-\\S+-\\S+)";
final String string = "This 1-A16-19 person is BL-17-1111 and other\n"
+ "dont Z-1-12 do here but NOT 12-24-1981\n"
+ "numbers: 1A-256-29Q88 ok";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}