import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=.*\\bfoo\\b)(?=.*\\bbar\\b)(?=.*\\bfoobar\\b)(?=.*\\bfootable\\b)(?=.*\\bsomebar\\b)^(?:\\w+\\s+){4}\\w+$";
final String string = "foo bar foobar footable somebar\n"
+ "foo bar footable somebar\n"
+ "foobar foo bar footable somebar\n"
+ "foo bar foobar footable somebar footable\n"
+ "foobar foo bar xyz somebar\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}