import re
regex = re.compile(r"(?=.*\bfoo\b)(?=.*\bbar\b)(?=.*\bfoobar\b)(?=.*\bfootable\b)(?=.*\bsomebar\b)^(?:\w+\s+){4}\w+$", flags=re.MULTILINE)
test_str = ("foo bar foobar footable somebar\n"
"foo bar footable somebar\n"
"foobar foo bar footable somebar\n"
"foo bar foobar footable somebar footable\n"
"foobar foo bar xyz somebar\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")