const regex = /(?=.*\bfoo\b)(?=.*\bbar\b)(?=.*\bfoobar\b)(?=.*\bfootable\b)(?=.*\bsomebar\b)^(?:\w+\s+){4}\w+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?=.*\\bfoo\\b)(?=.*\\bbar\\b)(?=.*\\bfoobar\\b)(?=.*\\bfootable\\b)(?=.*\\bsomebar\\b)^(?:\\w+\\s+){4}\\w+$', 'gm')
const str = `foo bar foobar footable somebar
foo bar footable somebar
foobar foo bar footable somebar
foo bar foobar footable somebar footable
foobar foo bar xyz somebar
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}