#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\d+[.,]?\d*$|^[.,]\d*$"
Local $sString = "" & @CRLF & _
"111." & @CRLF & _
"11." & @CRLF & _
"11," & @CRLF & _
"1111," & @CRLF & _
".123" & @CRLF & _
",.123" & @CRLF & _
"11.," & @CRLF & _
",123." & @CRLF & _
"11.," & @CRLF & _
",." & @CRLF & _
"," & @CRLF & _
".1" & @CRLF & _
"asdf" & @CRLF & _
",12312" & @CRLF & _
".12," & @CRLF & _
"1231." & @CRLF & _
"1231,." & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")