// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\d+[.,]?\d*$|^[.,]\d*$").unwrap();
let string = "
111.
11.
11,
1111,
.123
,.123
11.,
,123.
11.,
,.
,
.1
asdf
,12312
.12,
1231.
1231,.
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}