import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\d+[.,]?\\d*$|^[.,]\\d*$";
final String string = "\n"
+ "111.\n"
+ "11.\n"
+ "11,\n"
+ "1111,\n"
+ ".123\n"
+ ",.123\n"
+ "11.,\n"
+ ",123.\n"
+ "11.,\n"
+ ",.\n"
+ ",\n"
+ ".1\n"
+ "asdf\n"
+ ",12312\n"
+ ".12,\n"
+ "1231.\n"
+ "1231,.\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}