package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d+[.,]?\d*$|^[.,]\d*$`)
var str = `
111.
11.
11,
1111,
.123
,.123
11.,
,123.
11.,
,.
,
.1
asdf
,12312
.12,
1231.
1231,.
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}