re = /^\d+[.,]?\d*$|^[.,]\d*$/m
str = '
111.
11.
11,
1111,
.123
,.123
11.,
,123.
11.,
,.
,
.1
asdf
,12312
.12,
1231.
1231,.
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end