#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)(?<=(UTC|GMT))([+-])((\d{2}:\d{2})|(\d{4}|\d{2}))\b"
Local $sString = "UTC+02:00" & @CRLF & _
"UTC-04" & @CRLF & _
"UTC" & @CRLF & _
"UTC-0400" & @CRLF & _
"UTC+02:00" & @CRLF & _
"UTC+2" & @CRLF & _
"UTC-04:00" & @CRLF & _
"UTC-04" & @CRLF & _
"UTC+02" & @CRLF & _
"UTC+020" & @CRLF & _
"UTC-040"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")