re = /(?<=(UTC|GMT))([+-])((\d{2}:\d{2})|(\d{4}|\d{2}))\b/mi
str = 'UTC+02:00
UTC-04
UTC
UTC-0400
UTC+02:00
UTC+2
UTC-04:00
UTC-04
UTC+02
UTC+020
UTC-040'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end