$re = '/(?<=(UTC|GMT))([+-])((\d{2}:\d{2})|(\d{4}|\d{2}))\b/mi';
$str = 'UTC+02:00
UTC-04
UTC
UTC-0400
UTC+02:00
UTC+2
UTC-04:00
UTC-04
UTC+02
UTC+020
UTC-040';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);