use strict;
my $str = 'UTC+02:00
UTC-04
UTC
UTC-0400
UTC+02:00
UTC+2
UTC-04:00
UTC-04
UTC+02
UTC+020
UTC-040';
my $regex = qr/(?<=(UTC|GMT))([+-])((\d{2}:\d{2})|(\d{4}|\d{2}))\b/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}