const regex = /(?<=(UTC|GMT))([+-])((\d{2}:\d{2})|(\d{4}|\d{2}))\b/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=(UTC|GMT))([+-])((\\d{2}:\\d{2})|(\\d{4}|\\d{2}))\\b', 'gmi')
const str = `UTC+02:00
UTC-04
UTC
UTC-0400
UTC+02:00
UTC+2
UTC-04:00
UTC-04
UTC+02
UTC+020
UTC-040`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}