using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=^.{1,50}$)^[a-zA-Z]+([ \-'][a-zA-Z]+)*?$";
string input = @"5
-- should fail
foster
-- should match
foster steve
-- should match
foster-morrison
-- should match
hello
-- should match
*RKER(($(#$)#$#L$KLK#$*
-- should fail
dfkfsdkfskdfjksjfksfksjfskjfksjfskfksjfksfksfskfd
-- should match
jkddkdkdkdkdkdkdkdkdkdkdkskdldkfdlkfdfkdfkdlkdkdkdffddfdfdfdgggfgfgfggggggg
-- should FAIL, too long
jkddkdkdkdkdkdkdkdkdkdkdkskdldkfdlkfdfkdfkdlkdkdkd-ffddfdfdfdgggfgfgfgggggggd
-- should FAIL, too long
dkfkerksf------aaa-----
-- should fail
test---me
-- should fail
test'''me
-- fails
foster-mo
-- should match
f-morrison
-- should match
griffith-joiner
-- should match
test-
-- should fail
-dkd
-- should fail
d'andre
-- should match
d'andre-jordan
-- should match
jordan-d'andre-joe-b'bob
-- should match
\b[a-zA-Z]+?\b :: matches a last name
\b[a-zA-Z]+? [a-zA-Z]+?\b :: matches a space'd last name
\b[a-zA-Z]+?\-[a-zA-Z]+?\b :: matches a hyphenated last name
\b[a-zA-Z]+?'[a-zA-Z]+?\b :: matches an apostrophie'd last name";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}