import re
regex = re.compile(r"(?=^.{1,50}$)^[a-zA-Z]+([ \-'][a-zA-Z]+)*?$", flags=re.MULTILINE)
test_str = ("5\n"
" -- should fail\n"
"foster\n"
" -- should match\n"
"foster steve\n"
" -- should match\n"
"foster-morrison\n"
" -- should match\n"
"hello\n"
" -- should match\n"
"*RKER(($(#$)#$#L$KLK#$*\n"
" -- should fail\n"
"dfkfsdkfskdfjksjfksfksjfskjfksjfskfksjfksfksfskfd\n"
" -- should match\n"
"jkddkdkdkdkdkdkdkdkdkdkdkskdldkfdlkfdfkdfkdlkdkdkdffddfdfdfdgggfgfgfggggggg\n"
" -- should FAIL, too long\n"
"jkddkdkdkdkdkdkdkdkdkdkdkskdldkfdlkfdfkdfkdlkdkdkd-ffddfdfdfdgggfgfgfgggggggd\n"
" -- should FAIL, too long\n"
"dkfkerksf------aaa-----\n"
" -- should fail\n"
"test---me\n"
" -- should fail\n"
"test'''me\n"
" -- fails\n"
"foster-mo\n"
" -- should match\n"
"f-morrison\n"
" -- should match\n"
"griffith-joiner\n"
" -- should match\n"
"test-\n"
" -- should fail\n"
"-dkd\n"
" -- should fail\n"
"d'andre\n"
" -- should match\n"
"d'andre-jordan\n"
" -- should match\n"
"jordan-d'andre-joe-b'bob\n"
" -- should match\n\n"
"\\b[a-zA-Z]+?\\b :: matches a last name\n"
"\\b[a-zA-Z]+? [a-zA-Z]+?\\b :: matches a space'd last name\n"
"\\b[a-zA-Z]+?\\-[a-zA-Z]+?\\b :: matches a hyphenated last name\n"
"\\b[a-zA-Z]+?'[a-zA-Z]+?\\b :: matches an apostrophie'd last name")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")