import Foundation
let pattern = #"(?=^.{1,50}$)^[a-zA-Z]+([ \-'][a-zA-Z]+)*?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
5
-- should fail
foster
-- should match
foster steve
-- should match
foster-morrison
-- should match
hello
-- should match
*RKER(($(#$)#$#L$KLK#$*
-- should fail
dfkfsdkfskdfjksjfksfksjfskjfksjfskfksjfksfksfskfd
-- should match
jkddkdkdkdkdkdkdkdkdkdkdkskdldkfdlkfdfkdfkdlkdkdkdffddfdfdfdgggfgfgfggggggg
-- should FAIL, too long
jkddkdkdkdkdkdkdkdkdkdkdkskdldkfdlkfdfkdfkdlkdkdkd-ffddfdfdfdgggfgfgfgggggggd
-- should FAIL, too long
dkfkerksf------aaa-----
-- should fail
test---me
-- should fail
test'''me
-- fails
foster-mo
-- should match
f-morrison
-- should match
griffith-joiner
-- should match
test-
-- should fail
-dkd
-- should fail
d'andre
-- should match
d'andre-jordan
-- should match
jordan-d'andre-joe-b'bob
-- should match
\b[a-zA-Z]+?\b :: matches a last name
\b[a-zA-Z]+? [a-zA-Z]+?\b :: matches a space'd last name
\b[a-zA-Z]+?\-[a-zA-Z]+?\b :: matches a hyphenated last name
\b[a-zA-Z]+?'[a-zA-Z]+?\b :: matches an apostrophie'd last name
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)