use strict;
my $str = '5
-- should fail
foster
-- should match
foster steve
-- should match
foster-morrison
-- should match
hello
-- should match
*RKER(($(#$)#$#L$KLK#$*
-- should fail
dfkfsdkfskdfjksjfksfksjfskjfksjfskfksjfksfksfskfd
-- should match
jkddkdkdkdkdkdkdkdkdkdkdkskdldkfdlkfdfkdfkdlkdkdkdffddfdfdfdgggfgfgfggggggg
-- should FAIL, too long
jkddkdkdkdkdkdkdkdkdkdkdkskdldkfdlkfdfkdfkdlkdkdkd-ffddfdfdfdgggfgfgfgggggggd
-- should FAIL, too long
dkfkerksf------aaa-----
-- should fail
test---me
-- should fail
test\'\'\'me
-- fails
foster-mo
-- should match
f-morrison
-- should match
griffith-joiner
-- should match
test-
-- should fail
-dkd
-- should fail
d\'andre
-- should match
d\'andre-jordan
-- should match
jordan-d\'andre-joe-b\'bob
-- should match
\\b[a-zA-Z]+?\\b :: matches a last name
\\b[a-zA-Z]+? [a-zA-Z]+?\\b :: matches a space\'d last name
\\b[a-zA-Z]+?\\-[a-zA-Z]+?\\b :: matches a hyphenated last name
\\b[a-zA-Z]+?\'[a-zA-Z]+?\\b :: matches an apostrophie\'d last name';
my $regex = qr/(?=^.{1,50}$)^[a-zA-Z]+([ \-'][a-zA-Z]+)*?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}