#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(0|\+\s?33|\+\s?377){1}\s{0,1}(\(0\)){0,1}\s?(6|7){1}(( |.){0,1}[0-9]{2}){4}"
Local $sString = "+ 377 6 07 30 25 36" & @CRLF & _
"+377 6 07 30 25 36" & @CRLF & _
"+ 33 6 07 30 25 36" & @CRLF & _
"+33 6 07 30 25 36" & @CRLF & _
"06 07 30 25 36" & @CRLF & _
"0607302536" & @CRLF & _
"+33 (0)6 07 30 25 36" & @CRLF & _
"+377 (0)6 07 30 25 36" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")