// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(0|\+\s?33|\+\s?377){1}\s{0,1}(\(0\)){0,1}\s?(6|7){1}(( |.){0,1}[0-9]{2}){4}").unwrap();
let string = "+ 377 6 07 30 25 36
+377 6 07 30 25 36
+ 33 6 07 30 25 36
+33 6 07 30 25 36
06 07 30 25 36
0607302536
+33 (0)6 07 30 25 36
+377 (0)6 07 30 25 36
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}