package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(0|\+\s?33|\+\s?377){1}\s{0,1}(\(0\)){0,1}\s?(6|7){1}(( |.){0,1}[0-9]{2}){4}`)
var str = `+ 377 6 07 30 25 36
+377 6 07 30 25 36
+ 33 6 07 30 25 36
+33 6 07 30 25 36
06 07 30 25 36
0607302536
+33 (0)6 07 30 25 36
+377 (0)6 07 30 25 36
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}