use strict;
my $str = '+ 377 6 07 30 25 36
+377 6 07 30 25 36
+ 33 6 07 30 25 36
+33 6 07 30 25 36
06 07 30 25 36
0607302536
+33 (0)6 07 30 25 36
+377 (0)6 07 30 25 36
';
my $regex = qr/^(0|\+\s?33|\+\s?377){1}\s{0,1}(\(0\)){0,1}\s?(6|7){1}(( |.){0,1}[0-9]{2}){4}/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}