#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[\w,\s-]{1,3}\.[a-zA-Z0-9]{2,4}$"
Local $sString = "a.exe" & @CRLF & _
"file" & @CRLF & _
"file." & @CRLF & _
"file.ext" & @CRLF & _
"File.jpg" & @CRLF & _
"hi.mp3" & @CRLF & _
"fil.d2" & @CRLF & _
"file.longextension" & @CRLF & _
"565gfgf.mov" & @CRLF & _
"file#gg.jpg" & @CRLF & _
"a.ps1" & @CRLF & _
"123.hui" & @CRLF & _
"123.123" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")