$re = '/^[\w,\s-]{1,3}\.[a-zA-Z0-9]{2,4}$/m';
$str = 'a.exe
file
file.
file.ext
File.jpg
hi.mp3
fil.d2
file.longextension
565gfgf.mov
file#gg.jpg
a.ps1
123.hui
123.123
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);