package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[\w,\s-]{1,3}\.[a-zA-Z0-9]{2,4}$`)
var str = `a.exe
file
file.
file.ext
File.jpg
hi.mp3
fil.d2
file.longextension
565gfgf.mov
file#gg.jpg
a.ps1
123.hui
123.123
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}