#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:https?:\/\/)?(?:www\.)?(?:m\.)?twitter\.com\/\w+\/status\/\d+"
Local $sString = "https://twitter.com/Twitt_erDev/status/850006245121695744" & @CRLF & _
"http://twitter.com/Twit1243terDev/status/850006245121695744" & @CRLF & _
"https://www.twitter.com/Twi234_tterDev/status/850006245121695744" & @CRLF & _
"http://www.twitter.com/TwitterDev/status/850006245121695744" & @CRLF & _
"http://m.twitter.com/Tw11itterDev/status/850006245121695744" & @CRLF & _
"https://m.twitter.com/Tw11itterDev/status/850006245121695744" & @CRLF & _
"www.twitter.com/Twitt11erDev/status/850006245121695744" & @CRLF & _
"m.twitter.com/Tw11itterDev/status/850006245121695744" & @CRLF & _
"twitter.com/Twitte345_rDev/status/850006245121695744"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")