use strict;
my $str = 'https://twitter.com/Twitt_erDev/status/850006245121695744
http://twitter.com/Twit1243terDev/status/850006245121695744
https://www.twitter.com/Twi234_tterDev/status/850006245121695744
http://www.twitter.com/TwitterDev/status/850006245121695744
http://m.twitter.com/Tw11itterDev/status/850006245121695744
https://m.twitter.com/Tw11itterDev/status/850006245121695744
www.twitter.com/Twitt11erDev/status/850006245121695744
m.twitter.com/Tw11itterDev/status/850006245121695744
twitter.com/Twitte345_rDev/status/850006245121695744';
my $regex = qr/^(?:https?:\/\/)?(?:www\.)?(?:m\.)?twitter\.com\/\w+\/status\/\d+/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}