import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:https?:\\/\\/)?(?:www\\.)?(?:m\\.)?twitter\\.com\\/\\w+\\/status\\/\\d+";
final String string = "https://twitter.com/Twitt_erDev/status/850006245121695744\n"
+ "http://twitter.com/Twit1243terDev/status/850006245121695744\n"
+ "https://www.twitter.com/Twi234_tterDev/status/850006245121695744\n"
+ "http://www.twitter.com/TwitterDev/status/850006245121695744\n"
+ "http://m.twitter.com/Tw11itterDev/status/850006245121695744\n"
+ "https://m.twitter.com/Tw11itterDev/status/850006245121695744\n"
+ "www.twitter.com/Twitt11erDev/status/850006245121695744\n"
+ "m.twitter.com/Tw11itterDev/status/850006245121695744\n"
+ "twitter.com/Twitte345_rDev/status/850006245121695744";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}