const regex = /^(?:https?:\/\/)?(?:www\.)?(?:m\.)?twitter\.com\/\w+\/status\/\d+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:https?:\\\/\\\/)?(?:www\\.)?(?:m\\.)?twitter\\.com\\\/\\w+\\\/status\\\/\\d+', 'gm')
const str = `https://twitter.com/Twitt_erDev/status/850006245121695744
http://twitter.com/Twit1243terDev/status/850006245121695744
https://www.twitter.com/Twi234_tterDev/status/850006245121695744
http://www.twitter.com/TwitterDev/status/850006245121695744
http://m.twitter.com/Tw11itterDev/status/850006245121695744
https://m.twitter.com/Tw11itterDev/status/850006245121695744
www.twitter.com/Twitt11erDev/status/850006245121695744
m.twitter.com/Tw11itterDev/status/850006245121695744
twitter.com/Twitte345_rDev/status/850006245121695744`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}