$re = '/^(?:https?:\/\/)?(?:www\.)?(?:m\.)?twitter\.com\/\w+\/status\/\d+/m';
$str = 'https://twitter.com/Twitt_erDev/status/850006245121695744
http://twitter.com/Twit1243terDev/status/850006245121695744
https://www.twitter.com/Twi234_tterDev/status/850006245121695744
http://www.twitter.com/TwitterDev/status/850006245121695744
http://m.twitter.com/Tw11itterDev/status/850006245121695744
https://m.twitter.com/Tw11itterDev/status/850006245121695744
www.twitter.com/Twitt11erDev/status/850006245121695744
m.twitter.com/Tw11itterDev/status/850006245121695744
twitter.com/Twitte345_rDev/status/850006245121695744';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);