using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<p>The post <a\s+.*?href="".*?""\s+.*?>.*?<\/a> appeared first on <a\s+.*?href="".*?""\s+.*?>.*?<\/a>.<\/p>
";
string input = @"<p>The post <a rel=""nofollow"" href=""link"" >title</a> appeared first on <a rel=""nofollow"" href=""Website.com"" >Website</a>.</p>
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}