const regex = /<p>The post <a\s+.*?href=".*?"\s+.*?>.*?<\/a> appeared first on <a\s+.*?href=".*?"\s+.*?>.*?<\/a>.<\/p>
/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<p>The post <a\\s+.*?href=".*?"\\s+.*?>.*?<\\\/a> appeared first on <a\\s+.*?href=".*?"\\s+.*?>.*?<\\\/a>.<\\\/p>
', 'gm')
const str = `<p>The post <a rel="nofollow" href="link" >title</a> appeared first on <a rel="nofollow" href="Website.com" >Website</a>.</p>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}